package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z])+(\d+)([]a-zA-Z]+)`)
var str = `A12b s17G
P34562Z q2576f H456z
a1A
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}