$re = '/([a-zA-Z])+(\d+)([]a-zA-Z]+)/';
$str = 'A12b s17G
P34562Z q2576f H456z
a1A
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);