using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"color[^\.]*(red|blue|black|Green)[^\.]*(red|blue|black|Green)[^\.]*(red|blue|black|Green)[^\.]*";
string input = @"favorite colors are red, blue and black. Mr. Green
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}