package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`color[^\.]*(red|blue|black|Green)[^\.]*(red|blue|black|Green)[^\.]*(red|blue|black|Green)[^\.]*`)
var str = `favorite colors are red, blue and black. Mr. Green
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}