package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w ]+(?:,[^ ]+)?$`)
var str = `Hello World
Hello, World
Hello,World
Hello,World World `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}