re = /^[\w ]+(?:,[^ ]+)?$/m
str = 'Hello World
Hello, World
Hello,World
Hello,World World '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end