package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z0-9-_]+)((\s)*)({)((\s)*)(([a-zA-Z0-9-_;:%]*\s*)*)(})`)
var str = `class1
{
display:none;
width:100%;
position:absolute;
}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}