re = /([a-zA-Z0-9-_]+)((\s)*)({)((\s)*)(([a-zA-Z0-9-_;:%]*\s*)*)(})/
str = 'class1
{
display:none;
width:100%;
position:absolute;
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end