package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/(?<domain>.*?)\/(?<tenant>.*?)\/(?<study>.*?)\/(?<rest>.*)$`)
var str = `http://vera-dev.stanford.edu/nuvalence/demo/test/hello/howare/you`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}