$re = '/^https?:\/\/(?<domain>.*?)\/(?<tenant>.*?)\/(?<study>.*?)\/(?<rest>.*)$/m';
$str = 'http://vera-dev.stanford.edu/nuvalence/demo/test/hello/howare/you';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);