#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bDL=(.+?)DH="
Local $sString = "::UNm DL=254 DH=409.3 DS=16.2" & @CRLF & _
"::UNm DL=254.3 DH=409.3 DS=16.2" & @CRLF & _
"::UNm DL=254.32 DH=409.3 DS=16.2" & @CRLF & _
"::UNm DL=254.325 DH=409.3 DS=16.2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")