re = /\bDL=(.+?)DH=/m
str = '::UNm DL=254 DH=409.3 DS=16.2
::UNm DL=254.3 DH=409.3 DS=16.2
::UNm DL=254.32 DH=409.3 DS=16.2
::UNm DL=254.325 DH=409.3 DS=16.2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end