import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(\\b\\w+\\.(?:\\s+\\w+|$)))";
final String string = "This study was aimed at designing production of isoeugenol and vanillin from eugenol of clove leaf oil and analyzing the potential product development financially. The specific objectives of this research work are: 1. Identify the isoeugenol and vanillin. 2. Model simulation of process design of isoeugenol and vanillin. 3. Study on financial feasibility and added value. This research is expected to provide maximum economic potential of eugenol to enhance the added value of clove leaf oil. The results showed that the FTIR and NMR products confirmed that isoeugenol and vanillin present in the synthesized product were identical to the reference standards. {FIND( @ngkbm_lb_to_kg , ., 0 )} )} , @ngkbm_lb_to_kg)} hello.world";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}