package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([_A-Za-z0-9-+]+(\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\.[A-Za-z0-9]+)*(\.[A-Za-z]{2,})(;|$))*$`)
var str = `abc@damkovnai.un;efg@damkovnai.un;hij.kumar@damkovnai.un;klm.verma@damkovnai.un;
abc@damkovnai.un;efg@damkovnai.un;hij.kumar@damkovnai.un;klm.verma@damkovnai.un
abc@damkovnai.un;efg@damkovnai.un; hij.kumar@damkovnai.un ; klm.verma@damkovnai.un`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}