use strict;
my $str = 'abc@damkovnai.un;efg@damkovnai.un;hij.kumar@damkovnai.un;klm.verma@damkovnai.un;
abc@damkovnai.un;efg@damkovnai.un;hij.kumar@damkovnai.un;klm.verma@damkovnai.un
abc@damkovnai.un;efg@damkovnai.un; hij.kumar@damkovnai.un ; klm.verma@damkovnai.un';
my $regex = qr/^([_A-Za-z0-9-+]+(\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\.[A-Za-z0-9]+)*(\.[A-Za-z]{2,})(;|$))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}