package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^-a-zA-Z.,\-()=\s\+:?!*\;><0-9]`)
var str = `this [is] not req!red`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}