$re = '/[^-a-zA-Z.,\-()=\s\+:?!*\;><0-9]/';
$str = 'this [is] not req!red';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);