re = /^((?:(?:^|\.)(?:\d|[1-9]\d|1\d{2}|2[0-4]\d|25[0-5])){4})$/
str = '192.68.35.35'
# Print the match result
str.match(re) do |match|
puts match.to_s
end