package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-([^-]*-[^-]*)\.[^.\s-]+$`)
var str = `https://www.abcd.efg/try-till-you-succedd.html`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}