re = /-([^-]*-[^-]*)\.[^.\s-]+$/
str = 'https://www.abcd.efg/try-till-you-succedd.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end