re = /""[^"]*""|(")([^"]*)(")/m
str = 'This is some^"text".This is also some ""TEST TEXT""
This is some "text". This is also some ""TEST TEXT""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end