const regex = /(?i)(?<!\S)like\s*'%".*?"%'/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?<!\\S)like\\s*\'%".*?"%\'', 'gm')
const str = `Select Count(distinct c.requestId) FROM Abc1Value c WHERE 1=1 and c.templateName is NULL AND (c.quickStatus IS NULL OR c.quickStatus = 'S') AND (c.sCode='MYCODE' OR exists (SELECT b.dseaReqId FROM drstSShareValue b WHERE b.dseaReqId=c.requestId and b.sCode='MYCODE')) AND (upper(c.licenseNo) like '%"12548"%' or upper(c.docLicenseNo) like '%""%' or upper(c.uncontrolledLicense) like '%""%' or upper(c.nonAuthNo) like '%""%' or upper(c.reAuthNo) like '%""%') and upper(c.grantedByCtryCode) like '%US%' `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}