$re = '/(?i)(?<!\S)like\s*\'%".*?"%\'/m';
$str = 'Select Count(distinct c.requestId) FROM Abc1Value c WHERE 1=1 and c.templateName is NULL AND (c.quickStatus IS NULL OR c.quickStatus = \'S\') AND (c.sCode=\'MYCODE\' OR exists (SELECT b.dseaReqId FROM drstSShareValue b WHERE b.dseaReqId=c.requestId and b.sCode=\'MYCODE\')) AND (upper(c.licenseNo) like \'%"12548"%\' or upper(c.docLicenseNo) like \'%""%\' or upper(c.uncontrolledLicense) like \'%""%\' or upper(c.nonAuthNo) like \'%""%\' or upper(c.reAuthNo) like \'%""%\') and upper(c.grantedByCtryCode) like \'%US%\' ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);