re = /^(?![IVX.]|[a-z)]).*$/m
str = 'a) prueba de inciso
I. prueba de fraccion
Prueba parrafo
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end