#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=sent: ).+(?= type)"
Local $sString = "19:54:05 10.10.8.5 [SERVER] Response sent: www.example.com. type A by 192.168.4.5" & @CRLF & _
"19:55:10 10.10.8.5 [SERVER] Response sent: ns1.example.com. type A by 192.168.4.5" & @CRLF & _
"19:55:23 10.10.8.5 [SERVER] Response sent: ns1.example.com. type A by 192.168.4.5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")