import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=sent: ).+(?= type)";
final String string = "19:54:05 10.10.8.5 [SERVER] Response sent: www.example.com. type A by 192.168.4.5\n"
+ "19:55:10 10.10.8.5 [SERVER] Response sent: ns1.example.com. type A by 192.168.4.5\n"
+ "19:55:23 10.10.8.5 [SERVER] Response sent: ns1.example.com. type A by 192.168.4.5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}