package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)M`)
var str = `107S33M15H
33M100S
12M100H33M`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}