$re = '/([A-Z]{2})\$/';
$str = '"US$40, AU$89, JP$200"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);