import re
regex = re.compile(r"([\S]*)[\s]+([\S]*[\s]+[\S]*)[\s]+([0-9]{1,2})\%", flags=re.IGNORECASE)
test_str = ("RY4 Asian Flavor 10-15%\n"
"RY4 Double Flavor 5%-15%\n"
"Smooth Flavor 2 drops per 5 ml\n"
"Spearmint Flavor <5% Very Strong\n"
"Strawberries and Cream Flavor 10-12%\n"
"Strawberry Flavor 3%-15%\n"
"Strawberry Kiwi 20% 1/5\n"
"Strawberry Ripe 15%\n"
"Sweet Cream Flavor 5-10% 4/5 recommended for combining fake butter taste\n"
"Sweet Tart: 10% 5/5 Tastes more like Smarties\n"
"Sweetener 2%-6%\n"
"Tangerine Flavor (oil based) 1-5% 5/5\n"
"Tiramisu Flavor 2-5% VERY strong\n"
"Toasted Almond Flavor 15%")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")