package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`width="([\d]*.[\d])"$`)
var str = `width="22.2"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}