$re = '/width="([\d]*.[\d])"$/';
$str = 'width="22.2"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);