const regex = /^(?=.*[0-9])(?=.*[a-zA-Z])(?!([a-zA-Z0-9]).*\1.*\1.*)[a-zA-Z0-9]{3,16}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[0-9])(?=.*[a-zA-Z])(?!([a-zA-Z0-9]).*\\1.*\\1.*)[a-zA-Z0-9]{3,16}$', 'gm')
const str = `3er
232d2
2ddd42jj`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}