$re = '/^(?=.*[0-9])(?=.*[a-zA-Z])(?!([a-zA-Z0-9]).*\1.*\1.*)[a-zA-Z0-9]{3,16}$/m';
$str = '3er
232d2
2ddd42jj';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);