#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(\d+(?:st|th|[rn]d))\s+Meeting\s*-\s*)?(.*?)\s*(?:\[(\d+\s+(?:January|February|March|April|May|June|July|August|September|November|December)\s+\d{4})\s+to\s+((?:\d{1,2}\s+(?:January|February|March|April|May|June|July|August|September|November|December)\s+\d{4}))\])?$"
Local $sString = "24th Meeting - The quick brown fox [10 January 2012 to 26 September 2012]" & @CRLF & _
"12th Meeting - Lorem ipsum dolor sit amet"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")