const regex = /\b(\d\.\d+)\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d\\.\\d+)\\b', '')
const str = `neki text 133.00 ima dodatno vrednost 3.00 itd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}