package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`link:.*`)
var str = `link:HelloWorld
link:165848`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}