$re = '/link:.*/';
$str = 'link:HelloWorld
link:165848';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);