#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\w):(?=\w[^<>]*>)(?!\w+=)"
Local $sString = "<ns:Documents xmlns:ttn="http://fsrar.ru/WEGAIS/ReplyNoAnswerTTN" xmlns:ns="http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01" class=" FB_FW_ext BlitzScPluginAdapter">" & @CRLF & _
"<ns:Owner>" & @CRLF & _
"<ns:FSRAR_ID>3463047</ns:FSRAR_ID>" & @CRLF & _
"</ns:Owner>" & @CRLF & _
"<ns:Document>" & @CRLF & _
"<ns:ReplyNoAnswerTTN xmlns:ttn="http://fsrar.ru/WEGAIS/ReplyNoAnswerTTN" xmlns:ns="http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">" & @CRLF & _
"<ttn:Consignee>030000414982</ttn:Consignee>" & @CRLF & _
"<ttn:ReplyDate>2020-09-09T15:30:17.893</ttn:ReplyDate>" & @CRLF & _
"<ttn:ttnlist xmlns:ttn="http://fsrar.ru/WEGAIS/ReplyNoAnswerTTN" xmlns:ns="http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">" & @CRLF & _
"<ttn:NoAnswer xmlns:ttn="http://fsrar.ru/WEGAIS/ReplyNoAnswerTTN" xmlns:ns="http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">" & @CRLF & _
"<ttn:WbRegID>TTN-0407756344</ttn:WbRegID>" & @CRLF & _
"<ttn:ttnNumber>РН00012138</ttn:ttnNumber>" & @CRLF & _
"<ttn:ttnDate>2020-09-05</ttn:ttnDate>" & @CRLF & _
"<ttn:Shipper>030000009719</ttn:Shipper>" & @CRLF & _
"</ttn:NoAnswer>" & @CRLF & _
"</ttn:ttnlist>" & @CRLF & _
"</ns:ReplyNoAnswerTTN>" & @CRLF & _
"</ns:Document>" & @CRLF & _
"</ns:Documents>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")