# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\w):(?=\w[^<>]*>)(?!\w+=)"
test_str = ("<ns:Documents xmlns:ttn=\"http://fsrar.ru/WEGAIS/ReplyNoAnswerTTN\" xmlns:ns=\"http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01\" class=\" FB_FW_ext BlitzScPluginAdapter\">\n"
"<ns:Owner>\n"
"<ns:FSRAR_ID>3463047</ns:FSRAR_ID>\n"
"</ns:Owner>\n"
"<ns:Document>\n"
"<ns:ReplyNoAnswerTTN xmlns:ttn=\"http://fsrar.ru/WEGAIS/ReplyNoAnswerTTN\" xmlns:ns=\"http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\">\n"
"<ttn:Consignee>030000414982</ttn:Consignee>\n"
"<ttn:ReplyDate>2020-09-09T15:30:17.893</ttn:ReplyDate>\n"
"<ttn:ttnlist xmlns:ttn=\"http://fsrar.ru/WEGAIS/ReplyNoAnswerTTN\" xmlns:ns=\"http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\">\n"
"<ttn:NoAnswer xmlns:ttn=\"http://fsrar.ru/WEGAIS/ReplyNoAnswerTTN\" xmlns:ns=\"http://fsrar.ru/WEGAIS/WB_DOC_SINGLE_01\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\">\n"
"<ttn:WbRegID>TTN-0407756344</ttn:WbRegID>\n"
"<ttn:ttnNumber>РН00012138</ttn:ttnNumber>\n"
"<ttn:ttnDate>2020-09-05</ttn:ttnDate>\n"
"<ttn:Shipper>030000009719</ttn:Shipper>\n"
"</ttn:NoAnswer>\n"
"</ttn:ttnlist>\n"
"</ns:ReplyNoAnswerTTN>\n"
"</ns:Document>\n"
"</ns:Documents>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.