import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?=\\S*(?:fass|arbeit))(\\S*?)a(\\S*)\\b";
final String string = "a\n"
+ "fa\n"
+ "fas\n"
+ "fass\n"
+ "sasafrass\n"
+ "afass\n"
+ "fassa\n"
+ "blarg\n"
+ "arbei\n"
+ "farbei\n"
+ "arbeit\n"
+ "farbeit\n"
+ "arbeits\n"
+ "farbeits\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}