$re = '/\b(?=\S*(?:fass|arbeit))(\S*?)a(\S*)\b/m';
$str = 'a
fa
fas
fass
sasafrass
afass
fassa
blarg
arbei
farbei
arbeit
farbeit
arbeits
farbeits
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);