$re = '/[\w-]+|[^\w-]/m';
$str = 'We are at Ignite Solutions! Their email-id is careers@ignitesol.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);