re = /[\w-]+|[^\w-]/m
str = 'We are at Ignite Solutions! Their email-id is careers@ignitesol.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end