# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https?:\\/\\/(?:www\.)?([a-z]+).*/$1/gm;t' <<< "http://www.mywebsiteameW1234.com"