use strict;
my $str = 'http://www.mywebsiteameW1234.com';
my $regex = qr/https?:\/\/(?:www\.)?([a-z]+).*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";