package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{2}\d{9}[A-Z]{2}`)
var str = `AZ123456789AZA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}