$re = '/[A-Z]{2}\d{9}[A-Z]{2}/m';
$str = 'AZ123456789AZA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);