$re = '/^(\P{Lu}*)(?=\([^()]*\)$)/m';
$str = 'foundation for economic education (FEE)
Found (NNN)
no it is Not(F123)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);