re = /^(\P{Lu}*)(?=\([^()]*\)$)/m
str = 'foundation for economic education (FEE)
Found (NNN)
no it is Not(F123)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end