$re = '/(?<=<tag1>[^<>]*)\.(?=[^<>]*<\/tag1>)/m';
$str = '<tag1>Quomodo restituendus locus Demosth. Olÿnth</tag1>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);